Challenge :

Install-SitecoreConfiguration : The term 'Install-SitecoreConfiguration' is not recognized as the name of a cmdlet,
function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the
path is correct and try again.
At C:\HILP20\SC9UP1\Install-Sitecore.ps1:17 char:1
+ Install-SitecoreConfiguration @certParams -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Install-SitecoreConfiguration:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

Install-SitecoreConfiguration : The term 'Install-SitecoreConfiguration' is not recognized as the name of a cmdlet,
function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the
path is correct and try again.
At C:\HILP20\SC9UP1\Install-Sitecore.ps1:26 char:1
+ Install-SitecoreConfiguration @solrParams
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Install-SitecoreConfiguration:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

 

HI Folks,

Recently I was installing Sitecore 9.0 Update-1.I was referring installation guide and run the PowerShell script (page number 28) for the sitecore installation.I got above error after running the script.

Solution :
After I was checking PowerShell version by using the command :  $PSVersionTable.PSVersion. PowerShell version is 5.0 but Sitecore 9.0 Update-1 is required PowerShell version 5.1 or later.

Power Shell Version Check
Power Shell Version Check

Now I need to update PowerShell version. Go to the Settings > Update & Security > Windows Update, and select Check for updates.

Windows Update
Windows Update

After updating PowerShell version, we will continue Sitecore installation process.